mac OSがMojaveにアップデートできない問題

色々なスタジオのメンテナンスをしていると色々な問題に遭遇します。

今回は以下のメッセージが出てmac OSのアップデートができないという問題。High SierraからMojaveへのアップデートによって発生しました。

エラーメッセージ

App StoreからMojaveにアップデートしようとすると以下のメッセージが。

Mojaveインストーラーを起動するとこんなメッセージが

mac OS Mojave インストールアプリケーションは破損しているためmacOSのインストールには使用できません

いやいや、AppStore経由でしかインストールできないようにしておいてそのメッセージは無いでしょう(^_^;)だいたいインストールアプリケーションってインストール以外に使いみちないんだから、インストールに使用できませんと言われましても(笑)。

問題となったmac

  • iMac Retina 4K 21.5-inch 2017
  • High Seirra 10.13
  • メモリ 16GB 2400 MHz DDR4
対象のmac iMac Retina 4K 2017

解決模索

捨ててもう一度ダウンロード

インストーラを削除、再ダウンロードをしてみても結果は同じでした。

システムの時計をズラしてみる

同じ問題に遭遇している先人がいたので、参考に対処してみました。その方法はシステムの時計をずらして再度トライするというもの。

以下の記事を参考に挑戦しました。お世話になりました、ありがとうございます。

しかし、以下のようにAppStoreに接続できず、先に進めない状態になって手詰まりとなりました。

システムの日付を手動設定することで回避できることもあるようです

High Sierraのアップデートを適応してみる

なんらかのシステム的問題が原因と推測。ということは、OSに何か刺激を与えれば解決できるのではないかと考えました。よく見てみると、High Sierraも最新ではなく、アップデートが残っていました。

High Sierraのアップデートが残っていた!

とりあえずこれしかできることがなさそうなのでアップデートを適応。こちらは問題なくインストールできました。

High Sierraのアップデートが完了後、改めてMojaveをAppStoreからダウンロードすると、、、

インストーラー起動!

見事にインストールできるようになりましたヽ(=´▽`=)ノ

(Visited 675 times, 1 visits today)

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です